Solving works on 0.9.293, fails on later versions

Questions, support and discussions
schwim
Posts: 2
Joined: 13 Feb 2020, 05:22

Solving works on 0.9.293, fails on later versions

Post by schwim » 13 Feb 2020, 05:32

Hi.

I found a possible problem when troubleshooting solving an image on OSX build 0.9.315. This image in Ha and others like it would not solve:

https://www.dropbox.com/s/6e2vtanx0ukmc ... .fits?dl=0

However images of the same object using the L filter *do* solve:

https://www.dropbox.com/s/91c7isjhbazm5 ... .fits?dl=0

I tested the same images on my Linux machine running 0.9.293 and *both* the Ha and L solve. I then upgraded the linux install 0.9.319 and the Ha images no longer solve, similar to 0.9.315 on OSX.

NOTE: I tested all cases with the settings returned to defaults and ASTAP restarted after the reset.

han.k
Posts: 327
Joined: 23 Nov 2017, 15:04
Location: The Netherlands
Contact:

Re: Solving works on 0.9.293, fails on later versions

Post by han.k » 13 Feb 2020, 11:58

Hello Schwim,

That is always good to investigate. What I noted is that the image contains a lot of hot pixels. You can see the if you use the image inspector. The sensor was cooled to -25C but still a lot.

I'm not too worried that the older solves it. I improved the star detection for fainters stars and possible the latest version picks up more hot pixels.

I is nice to have a comparison for luminance and H-alpha.

What I will do is add a new filter for hot pixels. The average HFD is 6.3 and the pixel scale is 0.73"/pixel. This gives a seeing of about 4". The same as I see here. Any star smaller then maybe HFD=3 can be ignored. This seeing limit will be adjustable.

Will fix it today.

Clear skies,
Han

han.k
Posts: 327
Joined: 23 Nov 2017, 15:04
Location: The Netherlands
Contact:

Re: Solving works on 0.9.293, fails on later versions

Post by han.k » 13 Feb 2020, 14:28

Implemented this minimum star size in version 0.9.320 and issued it for Linux and Windows. The default is 1.5" but you could set a little higher since your stars are 4".

You image solves now without problems.

I played briefly with the old version 0.9.292, yes it solves your H-alpha image but is less good with other images.

The Mac version will follow in one or two days.

Clear skies, Han

schwim
Posts: 2
Joined: 13 Feb 2020, 05:22

Re: Solving works on 0.9.293, fails on later versions

Post by schwim » 13 Feb 2020, 20:25

Hi Han,

Tested 0.9.321 on linux and it works. I see the minimum star size setting as well. Thanks for the quick response and fix!

Greg

p.s. I'm not getting notifications on posts to the forum. I checked the settings and it all seems fine.

Post Reply