ASTAP aborted by invalid floating point operation

Questions, support and discussions
buur
Posts: 2
Joined: 21 Mar 2019, 16:26

ASTAP aborted by invalid floating point operation

Post by buur » 21 Mar 2019, 16:53

When I start stacking ASTAP will abort the staking process with the error:
"Invalid floating point operation.
Press Ok to ignore and risk data corruption.
Press Abort and kill the program."

When I press Ok. nothing happens.
Working with version 0.9.190 dated 2019-3-21 Windows

Unfortunately I have no idea where I can find the error log.

If I can help you with more information, please feel free and ask.

With best regards.
Thomas

han.k
Posts: 195
Joined: 23 Nov 2017, 15:04
Location: The Netherlands
Contact:

Re: ASTAP aborted by invalid floating point operation

Post by han.k » 23 Mar 2019, 13:47

Hello Thomas,

Sorry for the late response. I like to investigate. Could you reproduce the problem and provide me with some of your files for testing?

-Can you load files your using in the viewer (double click on the file list)
-Does it happen with all files. What happens if you select a few files only?

Han

buur
Posts: 2
Joined: 21 Mar 2019, 16:26

Re: ASTAP aborted by invalid floating point operation

Post by buur » 26 Mar 2019, 10:42

Hello Han, sorry for the late response, but I have the pictures on my PC at work.

- I can reproduce the problem.
- Loading files in the viewer is working.
- Also it happens when I work with only two files.

Also I found no information in the log.

I've uploaded two pictures. https://drive.google.com/open?id=1vGjdr ... zzstgA9wXm

Thomas

han.k
Posts: 195
Joined: 23 Nov 2017, 15:04
Location: The Netherlands
Contact:

Re: ASTAP aborted by invalid floating point operation

Post by han.k » 26 Mar 2019, 18:24

Hello Thomas,

Fixed this in version 0.9.193.

The problem was cause be the very very high background values. For green up to 42000. The program can now handle these almost maximum value. Try to expose much shorter next time. Maybe 60 seconds.

Aligning the images is a problem since many stars are oval shaped. Maybe it works better with darks but I could only align proper with external astrometry.net.

The green has a very stark signal. You can correct the colour with F9.

For demosaic, use setting Bayer pattern setting GB.

If you have more problems, please ask.

Regards, Han

Post Reply