errors trying to install the RPM

Questions, support and discussions
xsnrg
Posts: 2
Joined: 05 Jan 2020, 01:35

errors trying to install the RPM

Post by xsnrg » 05 Jan 2020, 01:38

Hello, I am running Fedora 31 on a 64 bit system. When I try to install the latest build, I get these errors:

Code: Select all

Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction test error:
  file / from install of astap-0.9.309-1.x86_64 conflicts with file from package filesystem-3.12-2.fc31.x86_64
  file /opt from install of astap-0.9.309-1.x86_64 conflicts with file from package filesystem-3.12-2.fc31.x86_64
  file /usr from install of astap-0.9.309-1.x86_64 conflicts with file from package filesystem-3.12-2.fc31.x86_64
  file /usr/local from install of astap-0.9.309-1.x86_64 conflicts with file from package filesystem-3.12-2.fc31.x86_64
  file /usr/local/bin from install of astap-0.9.309-1.x86_64 conflicts with file from package filesystem-3.12-2.fc31.x86_64
  file /usr/share from install of astap-0.9.309-1.x86_64 conflicts with file from package filesystem-3.12-2.fc31.x86_64
  file /usr/share/applications from install of astap-0.9.309-1.x86_64 conflicts with file from package filesystem-3.12-2.fc31.x86_64

xsnrg
Posts: 2
Joined: 05 Jan 2020, 01:35

Re: errors trying to install the RPM

Post by xsnrg » 08 Jan 2020, 00:22

I am able to work around this by extracting the files from the RPM and just running them, so no rush.

han.k
Posts: 316
Joined: 23 Nov 2017, 15:04
Location: The Netherlands
Contact:

Re: errors trying to install the RPM

Post by han.k » 08 Jan 2020, 07:44

That's strange. The version 0.309 is the current version. The version 3.12-2, I can't explain. Never created that version.

For making the RPM version, I use the program alien on the debian package.

For the moment I can't explain or do anything.

Clear skies, Han

Post Reply