INDI Settings crash

Post a reply

This question is a means of preventing automated form submissions by spambots.
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is ON
[url] is ON
Smilies are ON

Topic review

Expand view Topic review: INDI Settings crash

Re: INDI Settings crash

by han.k » 07 Sep 2018, 08:02

I still like to solve the problem


Re: INDI Settings crash

by han.k » 31 Aug 2018, 19:20

Hello John,

I have it now running in simulation. First I had a small problem with LX90 is simulation but it is now working here with:

local host

What do you mean with:
The "use TCP/IP option" is ticked by default but it is on localhost and a different port number.

Which address and port number you intend to use?

What you could try in settings is to select LX90, but then don't connect telescope but hit the button "show INDI client"
Then in the INDI client select in the top: "SHOW full INDI communication". Then connect the LX90 from the first the TAB in the INDI panel and hopefully some communication is shown indicating the problem. Try to get a screen shot from the INDI panel before HNSKY closes.

If that is not possible, I could add an option in HNSKY to write the log to a file so it can be recovered.

The problem about star database is strange. Could you also try to switch off the stars in the object menu (ALT+B)


INDI Settings crash

by VTVL » 30 Aug 2018, 18:10

Hello Han,

I am testing HNSKY 4.0.0s on Ubuntu MATE 18.04.1. with regard to the INDI connection to the telescope.

The telescope is an LX-90 with the AutoStar controller.
An RPI with UM 16.04 hosts the INDI server and connects to the AutoStar by USB-RS232 converter.
My PC is on a LAN. A WLAN connection to the RPI functions well.

The INDI server is started at boot of the RPI.
On the PC the INDI Web Manager is started in a Browser. The appropriate profile is selected (CCD and Focuser simulators plus LX90).

Starting HNSKY, selecting File → Settings → Telescope

Click INDI Interface

Enter the IP of the RPI WLAN address (it has a different fixed address if connected to the LAN ).

Port no 7624 (INDI standard)

With the INDI Server started via the INDI Web Manager click the Connection INDI Server.
It goes green.

Select the name of the telescope pull down and click LX90.

Click Connection Telescope button.

Then HNSKY crashes and a box appears with the message that Settings is not responding Force Quit or Wait.

Also a send box appears with the message
Hallo northern sky 2018-08-30 17:53:22 terrestrial view, PPM is not responding.

This behaviour has occurred each time.

The INDI Server and the AutoStar are working (as tested with two other INDI equipped planetarium programs today. They still connect via INDI after the HNSKY crash.

The "use TCP/IP option" is ticked by default but it is on localhost and a different port number.

Please give instructions so that I can send you more diagnostic information.

-- John